Can't redeem winnings


I've got ether tied up in the "Will ETH be above $5 on February 29th". It will not let me redeem winnings. I get an error "Cannot connect to ethereum node". Are there any workarounds?


We need to wait for them to fix the geth node. really bad that it has been offline for 1 week.


I believe you can download your wallet, import it into your own geth node and then redeem through the old dap. But I do not know the command to sweep in the seed to geth...maybe someone could post how to load a encrypted wallet into geth. I know how to do it in eth but eth cannot work with gnosis.


you can use it everywhere where the light wallet is supported:
By the way - it should work again by now.


I still get "Connection error: can't connect to ethereum node" when redeeming winnings on "Will the price of ether be above $5 on February 29th?". I see the following in Chrome dev tools:

Failed to load resource: the server responded with a status of 500 (INTERNAL SERVER ERROR)

I have tried this in a new incognito window to be sure there is not an issue with chrome storage. I also tried it in Firefox and got the same error.


More info: I created a new account and tried to send shares to it from my original account that holds the shares and I see the same 500 (INTERNAL SERVER ERROR) in dev tools.


I have a theory that this is related to the contract running out of funds. I was able to sell 1 share (at only.95) and then 10 shares (at .94). Now I try to sell 10 shares and I get the 500 error. So now I cannot redeem winnings, sell shares or send shares. It appears my funds are indefinitely locked in the contract.


SOLVED: I started investigating the successful transactions and it appears that there is quite a bit of variance in the gas consumed by each redemption. If I tried to clear all 50 shares at once, it appears the contract would sequentially zero out the opposing positions. Apparently there was not enough gas to run them all in one batch. I reduced my sell size in random amounts and was able to eventually get all the ether out of the contract (a lost about 5 ETH in slippage). You can
see the successful transactions here (#30 - #39)

Sometimes I could take more shares out than others, probably dependent on how many "bidders" needed to be closed. I hope this gets addressed in the next version of gnosis.


We are almost sure that it is something else:
The transactions are created with the lightwallet and then send to a geth node. The error occures if the geth node does not accept the transaction. We updated to the latest geth node and there was a change that it will only broadcast transaction with a "secp256k n/2" signature value.

This is more or less random. So when you changed around values some created randomly valid signatures and others not.

Anyway - thanks for your investigation - we will try to fix it as soon as possible.


I also cannot redeem winnings. But my issue occurs with the "Ether market cap >$1B on 10/3" event. Instead of the "Cannot connect to ethereum node" message that charlieknoll gets, my transaction gets confirmed, but I still have the shares, still have a "redeem winnings" button, and do not have the eth. I have tried several times with the same result. Let me know if you need more details. Thank you.


I made a mistake and did not resolved it correctly - we now did and it is possible now.


Hi I clicked redeem winning and when I click on the link to the transaction it says value 0 wei


what exactly are you talking about:
This view? This only shows the right Ether value for buy transactions - for all other it shows 0. However - if you have a look at the redeem transaction on you should find the flow of Ether to your address. (the site is unfortunately not always fully working)


When I click the particular transaction in the transaction page it links to the details of the transaction show the the transaction fee, ie how many Sazbo, but the value is given as 0 wei


I've got a balance I can't withdraw and results I can't redeem...


wow all fixed now, good job!