Connection Error to Ethereum node


Hi- I am now receiving an error when I try to make any transaction:

"Connection Error: Cannot Connect to Ethereum Node..."

Is your node down by any chance?


I am also getting this error now. Probably down for now.


I see that this occurred 5 days ago. It still seems to be down as of this morning. Is there a fix being deployed. Thanks for showing the proof of concept, devs.


Getting the same error.


Have had the same error for the past few days as well.


This plus the lack of communication plus the rising value of ETH makes it hard not to be worried. I want to give GroupGnosis the benefit of the doubt, but it is essential that people on a betting platform have confidence they will be able to withdraw their winnings. Can we get an explanation as to what's going on with these connection errors and when we will be able to redeem our winnings?


So at the very least you can have confidence that you have access to your winnings. You can always fire up a geth node import your wallet and access the contract. That being said a comment/update would be nice...and speaking of betting, there are no bets to feed my growing addiction! Maybe hunchgame will launch soon.


we need to look into it and fix the remote node on our server. If you don't want to wait for this you can use your own geth node (change settings here:


Please let us know when it's fixed. Hope to check out the new version soon :smile:


Thanks. Do you have an estimate for approximately when it will be up and running again?


Should work now again - let us know if it does not.


Trying to redeem: What Rep. Candidate will win the Nevada caucuses?
Error: Transaction stuck, does not get included in block and no reward.

Trying to redeem: Will the price of Bitcoin be above $475 on February 29th, 2016?
Error: Transaction stuck, does not get included in block and no reward.


We need to look into it - it seems like geth is not reliably broadcasting transactions. Maybe it is something on our side - we need to investigate. I had the same problem - needed to create the transaction multiple times until if went trough.


I gave it a try and was able to get one transaction off, and no more after the first. I noticed one oddity I was able to redeem winnings from the contract that had been moved into closed, but not from the eth >5 contract which is still appearing in the shares section, even though the market is closed.

Also, I know you are busy but could you resolve the market for hunchgame as we are now past feburary?



On the other issue - I am almost 100% sure that it is not a problem of this specific market. It is almost for a sure some problem with geth not reliable broadcasting transactions. In addition there have been changes in the recent geth version to the rpc-interface - so we need to adapted the DAPP. In principal we have done it but it seems we missed something - at least I get the connection refused error again with the error message "invalid sender" on the browser console - we are working on it.


Only one market that i can't redeem now: What Rep. Candidate will win the Nevada caucuses?

It says the geth node is not there...


I still have this problem. I am trying to redeem Will the price of Bitcoin be above $475 on February 29th, 2016?


I'm still seeing the issue redeeming winnings. Just a heads up, digix's ethereum wallet is having the same issues. I can't get funds out. Is there a reference for importing the encrypted wallet into geth? I tried and it is not a valid geth wallet file. (I copied to keystore directory).


We finally found the problem. Light wallet is signing transaction but since a recent change in "geth" only a subset of them are valid: where secp256k n/2. Anyway - we fix it soon with a newer lightwallet verison.

To you question: In principal you can use any to transfer your ether. And in principal it is possible to convert the lightwallet file into a geth keystore file. However - I am not aware of such a tool to I guess you need to wait until we fix it - sorry.


So this is a horrible hack but I believe the process to convert to geth can be achieved using AlethZero and the Ethereum ethkey utility. You can import the gnosis wallet into AlethZero, once there you can dump the private key using

ethkey inspectbare --show-me-the-secret insert wallet name here

and then with the private key I believe you can them import the unincrypted key over to geth.

Let me know if that works/fails for you.