What's the reason some transactions stay pending


When i make a bet, the transaction is shown in the geth console and the transactions tab shows (1), in some cases the status "is pending" stays true, how come?

The market is open, and later bets work, so this is intermittent.


Hm - not sure. I myself had problems when I made a second transaction before the first was mined in a block. Than the second transaction would not get minded.

But you say it is your first transaction that sometimes got stuck?


Well it might not have been the first, im not really sure.

So if the first transaction hasn't been mined yet and you send another, there might be a problem?
I guess some of these issues will be solved when the "wallet" is onsite and not connected to local geth?


Well after few weeks later i managed to get my first shares, Meanwhile somehow #790.756 (yellow mark) was mine today for some reason....

So yeah my suggestion is instead of a tick mark, i'd prefer a clock mark. When i first saw the tick i thought the transaction was completed.


So, i have seen this "bug" as well. I believe I can reproduce part of it if I

1) Create a buy order for one outcome
2) Create a second buy order for a different outcome before the first order is published to the block-chain
a) This creates a condition where the second order has a cost associated with the cost of the outcome before "1" occurs(which would move the cost now of outcome 2)
b) I wonder if because the contract told you the price of "2" but that price would have changed if executed and since it cannot honor the price declared, it simply does not execute.
c) I wonder if "2" attempts to execute before "1" or in the same block as "1" then it creates some sort of collision as one or the other would need to change the price for buying the option

On a side note I have noticed that sometimes this bug relates to the site saying it cant load the wallet please re-load. This occurred outside the condition listed above(so these may or may not be linked). I tried purchasing 10 shares (ya I am a high roller) for all outcomes on one of the dem primary races and then selling the all others. The sell command would not go through for the 10 shares each time i tried the site would say the wallet cannot load, however, I was able to sell it in two blocks of 5...which was odd.

I can tinker some more if you like and properly document this bug over the next few markets if i see it emerge again.


Thanks guys for this information.

Just how it should work in general: we are running a geth node on our server (in principal you can chose to use your own in the options but I guess you are using the default settings) This node is used to build the correct unsigned transaction (for example by requesting the correct nonce for your account). Than the transaction is signed in your browser (when you enter the password) and the signed transaction is send to the node and forwarded to the network.

One problem (that I hope was fixed by now) was that the geth node forwards a transaction but if it makes it in an orphaned block than it a) does not rebroadcast the same transaction for the main chain and b) all future nonces are wrong so no more transactions get included. I guess after some time it creates a valid transaction again with the right nonce.

However - I think there is at least another bug - and we will continue to look into it. Again thanks for your information.


You are right - a clock mark is better - we will use this in our next version.


I have transactions still pending I made during DEVCON....I can't withdraw....nothing! It's really weird....How do I get my Eth back?


one thing you can try is to open it in another browser or an incognito window. How much Ether is on your account?